Hangup
1. Description
It is designed to force the end of a call.
This component is present in flow types like:
Voice.
The block (Fig.1(1)) is used in space to build the Flow. The settings panel for this component opens (Fig.1(2)) when you click on the block.
Fig. 1. Hangup component
1.1. Hangup block
The block consists of the following elements:
The name of the component;
In branch — receiving (connecting with the previous block) branch;
Out branch — outgoing (connecting with the following block) branch. When hovering over the Out field, a switch appears. The switch allows this component to be connected to a component that already has a connection.
The presence of an icon indicates that the switch is on, and this component can be connected to a component that already has a connection.
Changing the switch position removes the outgoing branch of this component.
The button deletes the block from the Flow Schema.
1.2. Hangup settings panel
It consists of the following elements:
Cause;
Break;
Limit;
Add description.
1.2.1. Cause
In this field, you can select the SIP code by which the call will end. The call will be terminated if the field is empty, regardless of the received SIP codes.
You can select from the drop-down list or set it manually.
1.2.2. Break
1.2.3. Limit
Fig. 2. Setting a limit
1.2.4. Add description
Fig. 3. Add description
- 1 1. Description
- 1.1 1.1. Hangup block
- 1.2 1.2. Hangup settings panel
- 1.2.1 1.2.1. Cause
- 1.2.2 1.2.2. Break
- 1.2.3 1.2.3. Limit
- 1.2.4 1.2.4. Add description